rvm で最新 Ruby にしてから Guard で Ruby のエラーとその解決法

Guard 実行したら次のようなエラーが出た。
Guard ないと俺の怠惰タイムが減ってしまうので危機を感じたぜ。

1
2
3
4
/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:777:in `report_activate_error': Could not find RubyGem guard (>= 0) (Gem::LoadError)
    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:211:in `activate'

    from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems.rb:1056:in `gem'
    from /usr/bin/guard:18

調べたら、rails 入れればいいんでない?ということで。

1
gem install rails

Rails のインストールは時間がかかったが、これで無事解決..しなかった。

sudo guard で実行できた、なにこれ?
うーむ、gem 周り含めて入れなおそうかな。

Loading Facebook Comments ...

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です